78% веб-сайта работает на PHP (3% на PHP 8)

134
78% веб-сайта работает на PHP (3% на PHP 8)
78% веб-сайта работает на PHP (3% на PHP 8)

Сегодня PHP используется почти в 78% всех сайтов, язык программирования которых мы знаем. На PHP работают такие популярные сайты, как Slack, Etsy, Wikipedia, WordPress, Mailchimp, Canva, Indeed, Investing.com и другие.

Однако в ближайшие месяцы многие сайты, не успевшие перейти на последнюю версию PHP 8.2.1, останутся с версиями, которые больше официально не поддерживаются. Поэтому убедитесь, что вы, по крайней мере, обеспечены бэкпортом.

Использование серверных языков программирования для веб-сайтов (источник: w3techs)
Использование серверных языков программирования для веб-сайтов (источник: w3techs)

PHP 7 EOL (конец жизни): Переходите на PHP 8.2.1!

PHP 7 EOL (конец жизни): Переходите на PHP 8!
PHP 7 EOL (конец жизни): Переходите на PHP 8!

PHP 7 был выпущен еще в 2015 году. Между тем, PHP 8 был выпущен в ноябре 2020 года, и по состоянию на май 2022 года только около 3% веб-сайтов на базе PHP используют его!

Это медленное внедрение PHP 8.2.1 очень скоро станет более приоритетным обновлением для организаций. PHP 7 больше не поддерживается.

Переходите на PHP 8.2.1
Переходите на PHP 8.2.1

Расширенная поддержка PHP 7.4 завершилась 28 ноября 2022 года. Приложения работают, однако их поддержка уже прекращена, и они подвержены риску уязвимостей безопасности, которые останутся неисправленными.

Кроме того, с 28 ноября 2022 года Microsoft больше не поддерживает PHP, и в основном дистрибутивы на базе Unix, такие как Linux, станут ОС, поддерживаемыми будущими версиями PHP c постоянными обновлениями функций, и обновлениями безопасности.

Если вы хотите перейти на PHP 8, прочтите это: Проверка совместимости PHP 8 и советы по производительности.

Отключение expose_php

Когда параметр  expose_php  включен, он сообщает всему миру, что на сервере используется PHP. Этот параметр php.ini также показывает, какая версия PHP установлена, о чем сообщают HTTP-заголовки (например, X-Powered-By: PHP/8.0.12). Для лучшей безопасности рекомендуется отключить этот параметр php.ini.